iPhone downgraded to 1.1.4

by Samm Bennett
About a week ago I purchased an iPhone development license and installed the new 2.0 firmware beta on my iPhone.  Since then my iPhone has been crashing like made, but I figured I was at Apple's whim.  However, things got worse.  At approximately 3 am today, my iPhone showed the "pink screen of death," meaning i needed to reactivate my iPhone.  Yet, XCode told me the 2.0 firmware was out of date, and Apple has yet to release a new firmware.

Think about that.

Apparently, every iPhone developer has a bricked iPhone (potentially iPod Touch developers as well) until Apple pushes a new beta.  There was no warning.  In my opinion, this is not excusable, especially considering the horrid stability of the last version.

So what did I do?  I managed to circumvent Apple and downgraded back to 1.1.4 using Liberty+.  Now I'm going to do what I should have done and wait until the absolute last second to upgrade my iPhone for dev purposes.